kaffeeringe.de

Ausprobiert: Ubuntu Experiment 2: Mein Hauptrechner

Nachdem ich mein Laptop schon vor einem Monat auf Ubuntu umgestellt habe, war es jetzt Zeit für Teil 2 des Experiments. Das Windows XP auf meinem Desktop-Rechner hat sich in den letzten Monaten in ein schleppendes, nervendes Etwas verwandelt. Wie das bei Windows XP nach 2 Jahren eben so ist. Da ich aber ab und zu doch noch einmal eine Runde zocke, kann ich nicht ganz auf Windows verzichten. Die Anforderung war also etwas komplizierter als auf dem Laptop. Dafür dachte ich, wären die Komponenten in meinem Hauptrechner einfacher zu konfigurieren als die sehr speziellen in meinem Laptop: Dachte ich…Ausgangspunkt: AMD 64 3500 mit einem SATA RAID 1 mit 2 160GB Platten und sowohl einer 160GB und einer 80GB IDE Platte. Auf dem RAID war mein altes Windows und da sind auch eine Reihe Dateien drauf, die ich gerne behalten wollte. Das RAID sollte ausschließlich zur Speicherung der Daten laufen, Windows sollte auf die 160GB IDE und Ubuntu auf die 80GB IDE. Dabei ist mir relativ egal, ob die Systeme gegenseitig zugreifen können. Das Windows soll wirklich nur zum Spielen sein.

1. Das Ubuntu Wiki empfiehlt erst Windows dann Ubuntu zu installieren. Also mach ich das. Ich zieh die RAID Festplatten ab, damit ich die nicht ausversehen überschreiben. Ich vergesse aber den USB Stick abzuziehen und prompt löscht ich die merkwürdige Mini-Partition… Ich Idiot. Egal. Ich habe ein Backup.

Windows braucht ewig, bis es auf der 80GB IDE Platte installiert ist und bootet dann nicht. Im Nachhinein würde ich sagen, ich hätte einfach die Bootreihenfolge ändern müssen. Die Idee hatte ich aber nicht und installiere deswegen Window noch einmal neu auf der 160er Platte. Als das läuft, beginne ich Ubuntu zu installieren.

Die Live-CD erkennt alle wichtigen Komponenten, so dass ich während der Installation ein wenig im Internet surfen kann. Am Ende der Installation ein Reboot: Grafik funktioniert nicht. Ich hab keine Lust mich durch irgendwelche Config-Dateien zu wühlen, also installiere ich einfach noch einmal neu. Danach läuft es auch. Allerdings nur bis ich das RAID wieder anstöpsel. Mit eingelegter Live-CD und dem Menüpunkt „Von erster Festplatte starten“ klappt es aber. Auch das Window im GRUB startet nicht.

2. Der Kampf gegen den Error 17 beginnt: GRUB findet den Linux-Kernel nicht. Ich habe alles mögliche ausprobiert, was am Ende geholfen hat, war die Änderung der Bootreihen… Ich dachte immer, Linux interessieren BIOS-Einstellungen nicht. Egal. Es läuft. Hat aber 4 Stunden gedauert. Wieder zurück zu Windows.

3. Spaß mit Windows: Ich installiere die Mainboardtreiber, das RAID wird wiedererkannt und ich habe ein neues Problem: Installiert ist Windows nach eigenem Empfinden auf c: – In dem Moment aber, in dem die RAID-Treiber geladen werden, ist das RAID c: und die IDE-Platte e:. Es beginnt also mein neues Windows zu booten, lädt die RAID-Treiber und setzt dann den Bootvorgang mit meinem alten Windows auf dem RAID fort.

Ich bin sicher, dass sich das auch nicht dadurch lösen lässt, dass ich das alte Windows lösche. Dann hat das neue Windows nur ein Problem, komplett zu starten. Also stelle ich die ursprüngliche Konfiguration wieder her und lasse unter Windows RAID RAID sein. Wie gesagt: Von Windows muss ich auf die Partition nicht unbedingt zugreifen.

4. Nach einigen Basiskonfigurationen unter Ubuntu stelle ich fest, dass die Entscheidung für doe AMD64-Version ein böser Fehler war: Ich hatte gehofft mit Ubuntu die volle Leistung meines Prozessors zu bekommen, doch leider müssen natürlich auch alle Anwendungen für amd64 kompiliert sein. Das sind die nicht. Die Liste in der Paketverwaltung ist wesentlich kürzer und wenn schon Programme wie Bluefish fehlen, mach ich mir keine Hoffnung, dass ich auf Dauer glücklich damit werde. Ich lade mir also die 386er Version von Ubuntu und bin begeistert vom integrierten Bittorrent-Client: Minimal und flott das Teil. Außerdem schon vorinstalliert. Am Ende installiere ich Ubuntu noch einmal. Diesmal ohne Probleme.

Vorläufiges Fazit
Jetzt laufen grundsätzlich Windows und Ubuntu auf meinem Rechner. So einfach wie ich dachte, wars aber dafinitiv nicht. Und so standard wie ich dachte, ist mein Rechner doch nicht. Die Logitech G15 Tastatur funktioniert nur grundsätzlich – die ganzen Zusatztasten und das LCD-Display laufen unter Ubuntu nicht. Das gleiche Problem hatte ich mit meiner Maus: An der Logitech MX510 funktionierten die Zusatztasten nicht. Für die hat aber MaYO in seinem Blog eine einfache Anleitung.

Ich muss glaube ich noch einiges tun, damit das System wieder so rund läuft wie es soll. Aber das ist ja immer nach einer Neuinstallation so. Ich wünschte, ich könnte den Rechner einfach jemandem in die Hand drücken und sagen: Installier mal!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Möchtest Du benachrichtigt werden, wenn Dir hier jemand antwortet?